[@] A light, but functional terminal emulator - LilyTerm _ O X
[Home] [Features] [Download] [Changelog] [Tips] [About]

Last version:

Testing:

0.9.9.4 -- February 27th, 2013 SHA1SUM: 1023778413015814cd14394f606d26dbce7600c2

Stable:

0.9.9.2 -- June 16th, 2012 SHA1SUM: e6ee57fc90c108aa80c27ac31f517f7f65faf06e

NOTE:

You need libvte-dev and gettext(optional) to build LilyTerm.

The following command is a good example for compiling LilyTerm under Linux:

./configure --prefix=/usr --sysconfdir=/etc/xdg
make
make install

Using GTK+ 3.x + libvte 2.9 to build LilyTerm is NOT recommended, LilyTerm is for GTK+2 only currently.

LilyTerm also supports autotools. You may use it to build LilyTerm if you have trouble whith the build-in building scripts. You need libvte-dev, autoconf, automake, gettext, libxml-parser-perl and intltool to build LilyTerm with autotools, and execute ./autogen.sh to create a suitable configure file.


Debian/Ubuntu/Mint

(Add the following lines to /etc/apt/sources.list)

Debian Squeeze:

deb http://debian.luna.com.tw/squeeze ./
deb-src http://debian.luna.com.tw/squeeze ./

Debian Wheezy/Sid or Linux Mint LMDE:

deb http://debian.luna.com.tw/wheezy ./
deb-src http://debian.luna.com.tw/wheezy ./

Ubuntu Lucid Lynx (10.04):

deb http://debian.luna.com.tw/lucid ./
deb-src http://debian.luna.com.tw/lucid ./

Ubuntu Natty Narwhal (11.04):

deb http://debian.luna.com.tw/natty ./
deb-src http://debian.luna.com.tw/natty ./

Ubuntu Oneiric Ocelot (11.10):

deb http://debian.luna.com.tw/oneiric ./
deb-src http://debian.luna.com.tw/oneiric ./

Ubuntu Precise Pangolin (12.04 LTS):

deb http://debian.luna.com.tw/precise ./
deb-src http://debian.luna.com.tw/precise ./

Ubuntu Quantal Quetzal (12.10) or Linux Mint:

deb http://debian.luna.com.tw/quantal ./
deb-src http://debian.luna.com.tw/quantal ./

After executing apt-get update, using the following command to install LilyTerm 0.9.9:

apt-get install lilyterm

Patches

[IceWM: A geometry patch for IceWM 1.3.7]

[VTE: A input method patch for Traditional Chinese input methodes]

[VTE: VTE CJK WIDTH patch for libvte-0.16.14] (Bug 542795)

[VTE: transparent background patch for libvte-0.24.x] (Bug 615232)